Home 게시판 커뮤니티 Q&A 멀티사이트에서 사이트 추가시 siteurl 설정 문제

6개 답변, 3 voices Last updated by Avatar of bada bada 7 월 전
  • Avatar of badabada
    Participant
    @bada
    #52636

    워드프레스 4.9.5–ko_KR 버전이구요.

    현재 멀티사이트 설정을 해서 정상적으로 사이트 추가해서 서브블로그 사이트를 만들었습니다.

    그런데 이상하게 일정 시간 지나서 다시 로그인을 해보면 알림판도 안들어가지고 글수정이나 등록도 안되더라고요.

    왜 안되지 이상해서 보니 아래 첨부한 이미지처럼

    사이트 설정에 siteurl 이 자꾸 저렇게 워드프레스 메인주소로 바뀌더라구요.

    신규로 서브사이트를 만드니까 기본값이 siteurl 과 home 주소가 같길래

    저렇게 바뀐 siteurl을 다시 home 주소와 같이 바꿔주면 잠시 동안 또 되다가

    새로 로그인하거나 로그아웃하거나 하면 또 메인주소 */wp 로 바뀌네요.

    워드프레스 처음 쓰는거라 이게 왜이런건지 전혀 모르겠습니다.

    좀 도와주세요.

     

  • Avatar of 082net082net
    Keymaster
    @082net
    #52639

    siteurl 은 워드프레스의 설치 경로입니다. 설정에서 바꾸어도 되돌아 가는게 다행인거죠. 안그랬다면 사이트 접속 자체에 문제가 발생합니다.

    알림판에 들어가 지지 않는 것은 워드프레스 코어의 설정 부분에 문제가 있는 것이 아니라 사용중인 플러그인/테마와 충둘 현상이 일어나는 것이거나, 주소체계를 잘못 잡아 두어서 일 것입니다.

    또한  wp-config.php 파일에  MULTISITE 관련 추가한 내용도 제대로 기입 되어 있는지 확인 해 보세요.

     

    Avatar of 082net
    Facebook 사용자 모임 그룹 도 함께 운영되고 있으며, 격 주로 미트업과 스터디를 진행하고 있으니 관심 있으신 분들의 많은 참여 바랍니다 🙂
    • Avatar of badabada
      Participant
      @bada
      #52641

      답변은 감사합니다만, 아무래도 답변해주신 것과 다른 내용인 것 같습니다.

      저 스샷의 경우는 메인 사이트가  아니고 멀티사이트기능으로 만든 서브사이트라서

      알림판 주소도 /wp/aaa/wp-admin.php 이런 식인데요.

      서브사이트도 siteurl이  /wp 가 맞나요? 아닌거 같아요.

       

      서브사이트의 원래 알림판 wp-admin.php 주소는 /wp/aaa/wp-admin.php  이고

      서브사이트 관리자는 wp/wp-admin.php 쪽은 접속이 안되고  /wp/aaa/wp-admin.php 여기만 접속가능 한데

      siteurl 이 /wp 로 바뀌고나면 서브사이트 메인화면 추가기능에 있는 로그인 버튼의 알림판 wp-admin.php 의 링크주소가

      걍 /wp/wp-admin.php 로 바뀌어 버리고 서브사이트 관리자는 접속을 못하고.

      최고관리자로 로그인해도 저 서브사이트 알림판을 접속할 방법이 없어집니다.

      사이트에서 siteurl을 /wp/aaa 로 바꿔주면 전부 정상으로 돌아옵니다.

  • Avatar of 워드크래커워드크래커
    Participant
    @wordcracker7
    #52643

    안녕하세요?

    정확하게 어떻게 멀티사이트를 구성했는지 알려주시면 답변을 하는데 도움이 될 것 같습니다.

    신규로 서브사이트를 만드니까 기본값이 siteurl 과 home 주소가 같길래

    ==> Siteurl과 home 주소가 같다는 말이 정확하게 어떻게 같다는 것인지 모르겠지만 서브사이트를 만들면 siteurl과 home 주소가 동일하게 되는 것이 정상 같습니다.

    아마 /wp 폴더에 워드프레스를 설치하고 Home 주소를 http://www.example.com처럼 /wp 폴더가 없는 주소로 설정하지 않았나 추정되네요. 이 때문에 설정이 잘못되어 꼬인 것이 아닐까 생각됩니다.

    /wp 폴더에 워드프레스를 설치하지 말고 루트에 설치하여 진행하면 설정 잘못으로 인한 오류를 줄일 수 있을 것입니다.

    제가 질문을 잘못 이해했다면 이 답변은 무시해주세요.

    Avatar of 워드크래커

    • 워드프레스 정보 제공 블로그: Visit
    • 워드프레스와 관련하여 문제 해결이 필요한 경우 문의해주세요.

    • Avatar of badabada
      Participant
      @bada
      #52644

      네. 말씀하신대로입니다.

      워드프레스는 /wp 에 설치했고

      인터넷보고 멀티사이트 설치를 진행했고 htaccess 와 wp-config.php 를 네트워크 설치에 나온대로 수정했습니다.

      그리고 알림판> 네트워크관리자> 사이트에서 서브사이트를 1개 추가한 상태입니다.

      /wp 에 설치된 기본사이트는 아무런 문제가 없는 상태인데

      /wp/test/ 로 서브사이트를 생성 한 상태에서

      다른 곳에서 /wp/test/wp-admin.php 에 접속해 로그인하거나 로그아웃하면

      서브사이트 /wp/test/ 의 siteurl 이 자꾸 /wp 로 변경 되어버립니다.

      서브사이트의 siteurl 이 wp로 바뀌어 버리니 /wp/test/wp-admin.php 에서 로그인해도

      로그인후 자동으로 /wp/wp-admin.php 로 바뀌는 거죠.

      현재 / 루트에는 다른걸 사용중이라서 워드프레스를 루트에 설치할 수가 없는 상황입니다.

      어떻게 해야 할지 모르겠습니다.

    • Avatar of 워드크래커워드크래커
      Participant
      @wordcracker7
      #52645

      저도 하위 폴더에 워프를 설치하고 멀티사이트를 구성했지만 그런 증상이 없었습니다.

      아마도 설정에서 미세한 오류가 있을 수도 있습니다. 처음부터 하나씩 짚어보면서 다시 진행해보면 좋을 듯 합니다.

  • Avatar of badabada
    Participant
    @bada
    #52646

    위에 두분 답변 감사드립니다.  일단 해결하게 되어서 자답 달아둡니다.

    아무래도 안되길래 기존 설치본에서 reset wp 플러그인을 다운받아 reset 하고 다시 멀티사이트 설정을 해서 테스트 해보니 동일한 문제가 나타났습니다.

    그래서 DB와 파일데이타를 몽땅 삭제했습니다.

    4.9.5 버전을 다시 다운로드 받아서 새로 설치했습니다.

    새로 설치하고 나니 해당 문제가 사라졌습니다.

    제 웹호스팅이 cafe24인데 거기 홈페이지에서 지원하는 자동설치버전으로 설치했었고 그동안 업그레이드를 해왔었는데…

    아무래도 구버전 파일이 남았거나 … 그게 영향을 미친 모양입니다.

    결국 완전 재설치로 해결되었네요.

     

3 답변 글타래를 보이고 있습니다
  • 답변은 로그인 후 가능합니다.