Home사용자 가이드워드프레스 설치 및 둘러보기워드프레스 서버 환경

워드프레스 서버 환경

워드프레스를 단순히 화려한 테마를 설치해서 홈페이지를 만드는 툴 정도로만 이해하는 거나, 오픈소스 프로젝트를 그저 '공짜'라고만 인식하는 것은 워드프레스의 장점과 단점을 제대로 이해하고 목적에 맞게 활용하는데 큰 장벽이 되곤 합니다.

워드프레스를 제대로 알기 위한 첫 걸음 으로써, 공식 워드프레스 About 페이지 의 내용들을 읽어보는 것은 아주 현명한 선택일 것입니다. 이 페이지에서는 이에 조금이나마 도움이 되고자 그 내용을 번역하고 정리하여 두었습니다.

원본 링크 : Requirements https://wordpress.org/about/requirements/

워드프레스를 실행하기 위해서 필요한 서버환경

  • PHP 버전 5.6 이상
  • MySQL 버전  5.6 이상 또는  MariaDB 버전 10.0 이상

최소요구사항은 위와 같습니다. 워드프레스를 실행하기위해서는 Apache 또는 Nginx 웹서버가 필요합니다, 그러나 PHP와 MySQL이 구동될 수 있다면 다른 서버환경에서도 가능합니다. 즉, 워드프레스에서는 모든 환경에서 테스트 할 수 없습니니다, 워드프레스 웹호스팅(each of the hosts on our hosting page)에서 확인하시기 바랍니다. 

노트 : 구버전의 환경이라면 최소사양은 PHP 5.2.4이상 또는 MySQL 5.0+이상의 환경에서 워드프레스를 실해할 수 있습니다. 하지만 이 환경은 지원 종료될 예정이며 실행에 문제가 있거나 보안상 공격 당할 수 있습니다.

정리

다음 내용을 복사해서 붙여넣기 하세요! Here’s a letter you can send to your host; copy and paste!

웹호스팅 계정에서 다음 내용을 지원하는지 알고 싶습니다.

  • PHP 5.6 이상
  • MySQL 5.6 이상
  • mod_rewrite Apache 모듈 설치

고맙습니다.!

보안을 위해 필요한 내용

 

웹호스팅은 PHP환경에서 워드프레스를 사용할때, 서버에서 사용하는 사용자 계정명(username)을 사용하지 않는 것이  보안상 안전합니다. 여러분의 웹호스팅 계정을 위해 어떤 보안 서비스를 제공하는지 웹호스팅 업체에게 문의하세요.

Was this article helpful to you? Yes No