Home 게시판 커뮤니티 Q&A 변하지 않는 링크 설정

10개 답변, 2 voices Last updated by  익명 15 년, 7 월 전
  • 익명 @
    #687

    아는분 도움으로 해결됐어요!!! 😛

    .htaccess 맨 윗줄에 options +Indexes +FollowSymlinks를 추가시키서 해결.

    http://pionelle.net/wp/2005/06/06/5

  • 익명 @
    #688

    변하지 않는 링크를 설정해서,
    http://aaa.com/archives/1

    같이 퍼마링크가 되었을때, 클릭하면 IE에서 404 File Not Found 에러가 나옵니다.

    변하지 않는 링크설정을 http://aaa.com/index.php/archives/1

    같이 설정하면 정상적으로 표시됩니다.

    그런데 제가 쓰는 웹호스팅 업체는 아래같이 답변을 주며 mod_rewrite 모듈이 설치되어 있다고 합니다.

    그러면 제가 웹호스팅 업체로 웹서버 설정을 알려줄게 있을까요?

    아래는 에러나는 링크입니다.
    http://www.pdaclub.org/blog/archives/140

    이 링크는 정상입니다.
    http://www.pdaclub.org/blog/?p=140

    그리고 이 링크에서 제목의 글자 간격이 떨어지는 이유를 혹시 아시는 분이 계시면 조언 좀 부탁드립니다.

  • 익명 @
    #693

    변하지 않는 링크를 설정해서,
    http://aaa.com/archives/1

    같이 퍼마링크가 되었을때, 클릭하면 IE에서 404 File Not Found 에러가 나옵니다.

    변하지 않는 링크설정을 http://aaa.com/index.php/archives/1

    같이 설정하면 정상적으로 표시됩니다.

    그런데 제가 쓰는 웹호스팅 업체는 아래같이 답변을 주며 mod_rewrite 모듈이 설치되어 있다고 합니다.

    그러면 제가 웹호스팅 업체로 웹서버 설정을 알려줄게 있을까요?

    아래는 에러나는 링크입니다.
    http://www.pdaclub.org/blog/archives/140

    이 링크는 정상입니다.
    http://www.pdaclub.org/blog/?p=140

    그리고 이 링크에서 제목의 글자 간격이 떨어지는 이유를 혹시 아시는 분이 계시면 조언 좀 부탁드립니다.

  • Avatar of 그림동화그림동화
    Keymaster
    @그림동화
    #689

    wordpress 폴더에 있는 .htacess 권한을 확인해 보세요.
    권한에서 읽기, 쓰기가 가능해야 합니다.
    해당 파일이 없으면 하나 만드세요.

  • Avatar of 그림동화그림동화
    Keymaster
    @그림동화
    #694

    wordpress 폴더에 있는 .htacess 권한을 확인해 보세요.
    권한에서 읽기, 쓰기가 가능해야 합니다.
    해당 파일이 없으면 하나 만드세요.

  • Avatar of pdaclubpdaclub
    Participant
    @pdaclub
    #690

    답변감사합니다.

    .htacess 권한을 666으로 준 상태입니다.
    권한 말고는 다른 것을 봐야 될 것은 없나요?

    웹호스팅 업체에서 저에게 준 답변인데요..
    다른 분들 블로그를 방문하면 mod_rewrite모듈만 설치하면 되지 웹호스팅
    업체로 특별한 웹서버 설정을 요청한다는 글은 본적이 없는데..
    요상하네요..

    blog/index.php/archives/140 이런식으로는 되요.

    “안녕하세요
    입주하신 서버에 mod_rewrite 모듈은 설치가 되어 있으며 활성화되어 있습니다.
    mod_rewrite 모듈사용시 웹서버 설정을 해주어야 하는 부분이 따로 있는지 알고 싶습니다.
    관련 링크를 보여주시면 확인 후 적용을 해드리겠습니다.
    서버 전체설정을 변경해야 할 경우에는 적용이 어려울수도 있지만 계정내 개별 설정이 가능한 옵션일경우 설정을 해드리도록 하겠습니다.
    감사합니다.”

  • Avatar of pdaclubpdaclub
    Participant
    @pdaclub
    #695

    답변감사합니다.

    .htacess 권한을 666으로 준 상태입니다.
    권한 말고는 다른 것을 봐야 될 것은 없나요?

    웹호스팅 업체에서 저에게 준 답변인데요..
    다른 분들 블로그를 방문하면 mod_rewrite모듈만 설치하면 되지 웹호스팅
    업체로 특별한 웹서버 설정을 요청한다는 글은 본적이 없는데..
    요상하네요..

    blog/index.php/archives/140 이런식으로는 되요.

    “안녕하세요
    입주하신 서버에 mod_rewrite 모듈은 설치가 되어 있으며 활성화되어 있습니다.
    mod_rewrite 모듈사용시 웹서버 설정을 해주어야 하는 부분이 따로 있는지 알고 싶습니다.
    관련 링크를 보여주시면 확인 후 적용을 해드리겠습니다.
    서버 전체설정을 변경해야 할 경우에는 적용이 어려울수도 있지만 계정내 개별 설정이 가능한 옵션일경우 설정을 해드리도록 하겠습니다.
    감사합니다.”

  • Avatar of pdaclubpdaclub
    Participant
    @pdaclub
    #691

    앓던 이가 빠진 것처럼 시원하네요. 해결했습니다.
    http://codex.wordpress.org/Using_Permalinks
    위 링크를 참조해서 제가 쓰고 있는 웹호스팅 업체로 알려줬습니다.

    “모든 설정이 맞는데도, 퍼마링크가 안되면 아파치 서버에서 .htaccess 을 무시하게 처리해서 그렇다고 하네요.
    예를 들면 아파치의 httpd.config 설정에서 AllowOverride directive 기능을 아래 예시같이 활성해줘야 된다고 합니다.
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory> “

    웹호스팅 업체에서 위같이 제 계정에서 따로 설정을 해주니까 지금은 잘됩니다.

  • Avatar of pdaclubpdaclub
    Participant
    @pdaclub
    #696

    앓던 이가 빠진 것처럼 시원하네요. 해결했습니다.
    http://codex.wordpress.org/Using_Permalinks
    위 링크를 참조해서 제가 쓰고 있는 웹호스팅 업체로 알려줬습니다.

    “모든 설정이 맞는데도, 퍼마링크가 안되면 아파치 서버에서 .htaccess 을 무시하게 처리해서 그렇다고 하네요.
    예를 들면 아파치의 httpd.config 설정에서 AllowOverride directive 기능을 아래 예시같이 활성해줘야 된다고 합니다.
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory> “

    웹호스팅 업체에서 위같이 제 계정에서 따로 설정을 해주니까 지금은 잘됩니다.

  • 익명 @
    #692

    안녕하세요.
    WP설치하고 이것저것 테스트 중인데요, permalink가 설정이 안돼서 골치가 아프네요.

    “모든 설정이 맞는데도, 퍼마링크가 안되면 아파치 서버에서 .htaccess 을 무시하게 처리해서 그렇다고 하네요.
    예를 들면 아파치의 httpd.config 설정에서 AllowOverride directive 기능을 아래 예시같이 활성해줘야 된다고 합니다.
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory> ”

    아무래도 위에 글 쓰신 분과 같은 문제인것 같아서, 호스팅 업체에 문의해서 모듈을 쓸수 있게 해주고, AllowOverride기능을 활성화 해달라고 요청했어요.

    그리고 난다음에 다시 .htaccess에 아무것도 안쓰고 WP가 설치되어 있는 디렉토리에 올린다음, 권한을 666을 주고나서 WP관리자 패널에서 permalink 설정을 “/%year%/%monthnum%/%day%/%post_id%” 로 주었더니, 자동으로 .htaccess가 업데이트 되었다고 나와요.(호스팅 업체에 문의하기 전까지는 자동으로 업데이트가 안되었어요.) 그런데, 문제는 이렇게 하고나면 WP의 모든 페이지에 접근이 불가능해진다는 거에요.

    다른 글을 읽어보니 혹시 안되면 root 디렉토리에 넣어보란 얘기를 보고, 그것도 시도해봤는데, 그렇게하면 WP에서 자동으로 업데이트를 못하더라구요.

    re-write 모듈 안쓰고 index.php를 넣어서 퍼머링크를 만들 수도 있는데, 기왕 만드는거 이쁘게 만들고 싶어요. :'(

    현재 고민 중인 페이지에요.
    http://pionelle.net/wp/?p=5

    무엇이 문제일까요? 아시는 분은 도움을~!!!

  • 익명 @
    #697

    안녕하세요.
    WP설치하고 이것저것 테스트 중인데요, permalink가 설정이 안돼서 골치가 아프네요.

    “모든 설정이 맞는데도, 퍼마링크가 안되면 아파치 서버에서 .htaccess 을 무시하게 처리해서 그렇다고 하네요.
    예를 들면 아파치의 httpd.config 설정에서 AllowOverride directive 기능을 아래 예시같이 활성해줘야 된다고 합니다.
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory> ”

    아무래도 위에 글 쓰신 분과 같은 문제인것 같아서, 호스팅 업체에 문의해서 모듈을 쓸수 있게 해주고, AllowOverride기능을 활성화 해달라고 요청했어요.

    그리고 난다음에 다시 .htaccess에 아무것도 안쓰고 WP가 설치되어 있는 디렉토리에 올린다음, 권한을 666을 주고나서 WP관리자 패널에서 permalink 설정을 “/%year%/%monthnum%/%day%/%post_id%” 로 주었더니, 자동으로 .htaccess가 업데이트 되었다고 나와요.(호스팅 업체에 문의하기 전까지는 자동으로 업데이트가 안되었어요.) 그런데, 문제는 이렇게 하고나면 WP의 모든 페이지에 접근이 불가능해진다는 거에요.

    다른 글을 읽어보니 혹시 안되면 root 디렉토리에 넣어보란 얘기를 보고, 그것도 시도해봤는데, 그렇게하면 WP에서 자동으로 업데이트를 못하더라구요.

    re-write 모듈 안쓰고 index.php를 넣어서 퍼머링크를 만들 수도 있는데, 기왕 만드는거 이쁘게 만들고 싶어요. :'(

    현재 고민 중인 페이지에요.
    http://pionelle.net/wp/?p=5

    무엇이 문제일까요? 아시는 분은 도움을~!!!

10 답변 글타래를 보이고 있습니다
  • 답변은 로그인 후 가능합니다.