Home 게시판 커뮤니티 Q&A post_nav_link 질문입니다.

8개 답변, 1 voice Last updated by Avatar of 그림동화 그림동화 15 년, 9 월 전
  • 익명 @
    #672

    옵션 부분을 제대로 읽어 볼 것을 그랬습니다.

    퍼머링크 태그에 /index.php/부분을 삽입하니 정상 동작합니다.

    그리고, 대표 도메인이 기간 만료된 상태로 등록 되어 있길래 현재 쓰고 있는 서브 도메인을 대표도메인으로 변경 신청하니 블로그 주소도 /wp/index.php에서 /wp로 간단하게 줄였습니다.

    그림동화님 도움 감사합니다.

  • 익명 @
    #673

    http://www.meilog.net/wp/index.php

    “포스트 네비게이션 링크” 관련해서 질문드립니다.

    메인 화면에서 포스트 아래 next 링크를 누르면 이전(포스팅시간) 엔트리로 넘어가질 않습니다.

    이유는 메인페이지에서 이전 포스트로 넘어가려면 url이

    http://www.meilog.net/wp/index.php/page/2/

    가 되어야 하는데 메인화면에서 next 위에 마우스를 올려보면

     http://www.meilog.net/wp/index.php/wp/page/2/

    wp/가 중간에 낀채 링크 위치를 넘긴 탓으로 보입니다.

    카테고리를 선택하거나 archives로 포스트를 읽을 때는 정상적으로 네비게이션이 동작하거든요. <이전>이든 <다음>이든.
    단지 메인화면에서만 이전(포스팅 시간상) 포스트를 읽기 위한 동작(next)가 올바로 동작을 하지 않는 상황입니다.

  • 익명 @
    #677

    http://www.meilog.net/wp/index.php

    “포스트 네비게이션 링크” 관련해서 질문드립니다.

    메인 화면에서 포스트 아래 next 링크를 누르면 이전(포스팅시간) 엔트리로 넘어가질 않습니다.

    이유는 메인페이지에서 이전 포스트로 넘어가려면 url이

    http://www.meilog.net/wp/index.php/page/2/

    가 되어야 하는데 메인화면에서 next 위에 마우스를 올려보면

     http://www.meilog.net/wp/index.php/wp/page/2/

    wp/가 중간에 낀채 링크 위치를 넘긴 탓으로 보입니다.

    카테고리를 선택하거나 archives로 포스트를 읽을 때는 정상적으로 네비게이션이 동작하거든요. <이전>이든 <다음>이든.
    단지 메인화면에서만 이전(포스팅 시간상) 포스트를 읽기 위한 동작(next)가 올바로 동작을 하지 않는 상황입니다.

  • Avatar of 그림동화그림동화
    Keymaster
    @그림동화
    #674

    (수정)

    1. 관리자 모드의 일반 설정에서 워드프레스 주소와 블로그 주소를 확인해 보세요

    2. 퍼머링크 설정이 잘못된었을지도 모릅니다.
    관리자 모드의 설정 (Option)>변하지 않는 링크 (permanent link)로 가서
    설정이 어떻게 되어있는지 보고 설정되어있는 태그를 우선 삭제해 보고 정상적으로 작동하는지 확인해 보세요.
    계속 동작이 이상하다면 다시 글을 올려주세요. ^^

  • Avatar of 그림동화그림동화
    Keymaster
    @그림동화
    #678

    (수정)

    1. 관리자 모드의 일반 설정에서 워드프레스 주소와 블로그 주소를 확인해 보세요

    2. 퍼머링크 설정이 잘못된었을지도 모릅니다.
    관리자 모드의 설정 (Option)>변하지 않는 링크 (permanent link)로 가서
    설정이 어떻게 되어있는지 보고 설정되어있는 태그를 우선 삭제해 보고 정상적으로 작동하는지 확인해 보세요.
    계속 동작이 이상하다면 다시 글을 올려주세요. ^^

  • 익명 @
    #675

    우선 답변에 감사드립니다.

    워드프레스 주소와 블로그 주소

    -wp설치는 계정에 /wp 폴더를 만들어 설치를 했고
    wp와 블로그 주소는 각각 url/wp, url/wp/index.php로 설정해둔 상태입니다.

    퍼머링크 설정

    퍼머링크 삭제시에는 네비게이션이 정상 동작합니다.
    그렇게 사용해도 별 스럴일은 없지만, 아무래도 url이 깔끔한게 좋은 것 같아서 미련을 못 버리겠네요.

    삭제전 structure는 /archives/%post_id% 로 해두었지만, 다른 태그를 사용해보아도 역시 메인에서만 네비게이션이 질문했던 대로 정상 동작하지 않습니다.

  • 익명 @
    #679

    우선 답변에 감사드립니다.

    워드프레스 주소와 블로그 주소

    -wp설치는 계정에 /wp 폴더를 만들어 설치를 했고
    wp와 블로그 주소는 각각 url/wp, url/wp/index.php로 설정해둔 상태입니다.

    퍼머링크 설정

    퍼머링크 삭제시에는 네비게이션이 정상 동작합니다.
    그렇게 사용해도 별 스럴일은 없지만, 아무래도 url이 깔끔한게 좋은 것 같아서 미련을 못 버리겠네요.

    삭제전 structure는 /archives/%post_id% 로 해두었지만, 다른 태그를 사용해보아도 역시 메인에서만 네비게이션이 질문했던 대로 정상 동작하지 않습니다.

  • Avatar of 그림동화그림동화
    Keymaster
    @그림동화
    #676

    사실 저도 원인을 잘 모르겠네요

    1. 블로그 주소에서 /index.php 부분을 삭제 해 보세요

    2. 설치 주소나 블로그 주소에서 혹시 서브도메인으로 설정해 하지 않았나
    확인 해 보세요.

    3. .htacess 권한이 666으로 되어있나 확인 해 보세요 ^^

  • Avatar of 그림동화그림동화
    Keymaster
    @그림동화
    #680

    사실 저도 원인을 잘 모르겠네요

    1. 블로그 주소에서 /index.php 부분을 삭제 해 보세요

    2. 설치 주소나 블로그 주소에서 혹시 서브도메인으로 설정해 하지 않았나
    확인 해 보세요.

    3. .htacess 권한이 666으로 되어있나 확인 해 보세요 ^^

8 답변 글타래를 보이고 있습니다
  • 답변은 로그인 후 가능합니다.