Home 게시판 커뮤니티 Q&A php version upgrade

Tagged
4개 답변, 5 voices Last updated by Avatar of EnteroaEnteroa 6 years, 2 months 전
  • Avatar of Jooha SongJooha Song
    Participant
    @toosol
    #36784

    mycity라는 guidemap에 특화된 템플릿을 구입해서 만져보고 있습니다.
    (지금 사는 동네를 소개하는 비영리 사이트를 구상중에 있습니다. 그냥 재능기부차원에서요)

    그런데 결정적으로 이 템플릿에 필요한 플러그인이 5.4 이상의 php를 요구합니다.
    wordpress 최신버전인 4.6은 php 버전정보가 5.3.13.p1으로 되어 있구요.

    개인적으로 php version을 업그레이드해도 되나요?
    할려면 어떻게 해야 하나요?

    php에 대해서는 거의 무지합니다.
    고수님들의 배려 부탁드립니다.

    Avatar of Jooha Song
    1. 정년은퇴자
    2. wordpress homepage design 취미
    3. 최근 5년간 약 5개의 홈페이지 구축
    Avatar of 아이디어피플아이디어피플
    Participant
    @ideapeople
    #36790

    플러그인 충돌이 생길지도 모르지만 그냥 업그레이드 하셔도 별 문제 없으실것 같습니당…

    Avatar of codeicodei
    Participant
    @codei
    #36800

    콕집어서 5.4 이상이면 업그레이드 하셔야 합니다.

    보통은 5.3 이상을 요구할텐데 5.4 요구면 5.4이상 버전에 들어간 기능들을 사용 하나 보네요.

    이왕 하실 거면 7으로 올리시는 것도 도전해 보세요.

    Avatar of Matthew ParkMatthew Park
    Moderator
    @hackya
    #36813

    질문글을 자유게시판에 올리셔서 Q&A 로 이동시켜드렸습니다.

    “할려면 어떻게 해야 하나요?”

    php 버전을 상위버전으로 올리는 방법은 여러가지가 있는데, cPanel 이 제공되면 (거의 모든 웹호스팅에서 cPanel 제공합니다.) 거기 들어가서 하시는게 가장 쉬운 방법으로 알고 있습니다. 그냥 마우스 버튼 몇번 클릭 클릭 하면 끝이니까요.

    http://www.inmotionhosting.com/support/website/php/how-to-change-the-php-version-your-account-uses

    웹호스팅이 아니시고, 직접 우분투 서버를 돌리고 계셔서 최신 php 를 설치하셔야 하면,

    sudo apt-get install php7.0

    하시면 된다고 나와 있는데,

    http://askubuntu.com/questions/565784/how-do-i-upgrade-php-version-to-the-latest-stable-released-version

    제 localhost 면 모를까, 물론 저는 살떨려서 실제 사이트에는 이런거 못합니다.

    저는 그냥 서버담당한테 해달라고 합니다.

    “야, 고객님이 php 버전 올려달래.”

    이럼 끝. ㅋㅋㅋㅋ

    Avatar of Matthew Park
    Attorney, front-end developer, digital media artist, WordPress enthusiast, & a father of 4 wonderful children.

    Lives in Colorado.

    Avatar of EnteroaEnteroa
    Participant
    @san0123
    #36845

    php 버전을 보아하니 깡패24 쓰시는거 같은데 전화해서 php 5.5 버전으로 어찌 바꾸냐고 물어보시는게 빠릅니다 ‘ㅅ’a

5 글 보임 - 1에서 5 까지 (총 5 중에서)
  • 답변은 로그인 후 가능합니다.